High Severity Cross-site Scripting Vulnerability in Joomla! Detected with Invicti

Information

Advisory by Netsparker (now Invicti)
Name: XSS vulnerability in Joomla 1.6.3
Software: All 1.6.x installs prior to and including 1.6.3 are affected.
Vendor Homepage: http://www.joomla.org
Vulnerability Type: Cross-Site Scripting
Severity: High
Researcher: Mesut Timur
Advisory Reference: NS-11-009

Description

Joomla is an award-winning content management system (CMS), which enables you to build Web sites and powerful online applications. Many aspects, including its ease-of-use and extensibility, have made Joomla the most popular Web site software available. Best of all, Joomla is an open source solution that is freely available to everyone.

Details

Joomla is affected by a XSS vulnerability. All 1.6.x installs prior to and including 1.6.3 are affected.
You can read the full article about Cross-Site Scripting vulnerabilities from here: /blog/web-security/cross-site-scripting-xss/

Solution

Upgrade to the latest Joomla! version (1.6.4 or later).

Credits

It has been discovered on testing of Invicti Web Application Security Scanner.

References

  1. Vendor URL: http://developer.joomla.org/security/news/349-20110601-xss-vulnerabilities.html
  2. MSL Advisory Link: /xss-vulnerability-in-joomla-163/
  3. Invicti Advisories: /web-applications-advisories/

About Invicti

Invicti Security is transforming the way web applications are secured. Invicti empowers organizations in every industry to scale their overall security operations, make the best use of their security resources, and engage developers in helping to improve their overall security posture.