Information
--------------------
Advisory by Netsparker (now Invicti)
Name: Multiple XSS Vulnerabilities in BootstrapValidator
Affected Software: BootstrapValidator
Affected Versions: v0.5.3 and possibly below
Vendor Homepage: https://github.com/nghuuphuoc/bootstrapvalidator 
Vulnerability Type: Cross-site Scripting
Severity: Important
Status: Not Fixed
Invicti Advisory Reference: NS-15-022

Technical Details
--------------------
Proof of Concept URLs for XSS in BootstrapValidator v0.5.3:

Vulnerable Page: /bootstrapvalidator-master/demo/target.php

Vulnerable Params: lastName, company, country, phoneNumber, yearDayMonthTime, captcha, username, email, password, fullName, monthDayYear, yearDayMonth, confirmPassword, city, signup2, programs[], languages[], birthday, signup, gender, jobTitle, address, website, firstName, datetimePicker

Attack pattern: '"--></style></scRipt><scRipt>alert(0x009CA0)</scRipt> 

For more information on cross-site scripting vulnerabilities read the article Cross-site Scripting (XSS).

Advisory Timeline
--------------------
04/09/2015 - First Contact
16/11/2015 - Second Contact
15/12/2015 - Advisory Released

Solution
--------------------
The developer did not follow up / no solution is available.

Credits & Authors
--------------------
These issues have been discovered by Onur Yilmaz while testing Invicti Web Application Security Scanner.

About Invicti
--------------------
Invicti Security is transforming the way web applications are secured. Invicti empowers organizations in every industry to scale their overall security operations, make the best use of their security resources, and engage developers in helping to improve their overall security posture.